Alert GCSA-08027 – Vulnerabilita’ multiple in MIT Kerberos

Inserito da 21 Marzo, 2008

Si tratta di :Sicurezza


Descrizione del problema

Sono state individuate alcune vulnerabilita’ in MIT Kerberos che
potrebbero consentire ad un aggressore remoto di entrare in possesso
di informazioni sensibili, causare un denial-of-service o prendere
il completo controllo di un sistema vulnerabile.

La prima vulnerabilita’ e’ causata da un errore nella gestione delle
richieste krb4 da parte del KDC server (Key Distribution Center) che
puo’ portare al crash del sistema, dare accesso ad informazioni
sensibili (comprese le chivi segrete) ed esecuzione di codice
arbitrario.

La seconda vulnerabilita’ e’ causata da un errore presente nel KDC
server nel momento in cui manda risposta a richieste krb4. Tale
vulnerabilita’ puo’ essere sfruttata per accedere a dati sensibili
presenti nello stack della memoria attraverso richieste krb4
appositamente predisposte.

La terza vulnerabilita’ e’ causata da un errore di corruzione della
memoria nelle librerie RPC durante la gestione di un grande numero
di file descriptor aperti, e puo’ portare alla corruzione del
database e all’esecuzione di codice arbitrario.




Categories : Sicurezza Tags : , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , , ,



divisore

Commenti Via Facebook

Commenti lasciati dagli ospiti, senza usare Facebook

Commenti

Non ci sono commenti.


Inserisci un Commento

(richiesto)

(richiesta)



divisore